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STOP! THIS PRODUCTS HAS LEGAL RESTRICTIONS. READ THIS BEFORE INSTALLING/USING!
THIS PRODUCTS MAY BE USED SOLELY ON VEHICLES USED IN SANCTIONED COMPETITION WHICH MAY NEVER
BE USED UPON A PUBLIC ROAD OR HIGHWAY. IT IS THE RESPONSIBILITY OF THE INSTALLER AND/OR USER OF
THIS PRODUCT TO ENSURE THAT IT IS USED IN COMPLIANCE WITH ALL APPLICABLE LAWS AND REGULATIONS. IF
THIS PRODUCT WAS PURCHASED IN ERROR, DO NOT INSTALL AND/OR USE IT. THE PURCHASER MUST ARRANGE
TO RETURN THE PRODUCT FOR A FULL REFUND.THIS POLICY ONLY APPLIES TO INSTALLERS AND/OR USERS
WHO ARE LOCATED IN THE UNITED STATES; HOWEVER CUSTOMERS WHO RESIDE IN OTHER COUNTRIES
SHOULD ACT IN ACCORDANCE WITH THEIR LOCAL LAWS AND REGULATIONS.

Do not use this product until you have carefully read the following agreement.
This sets forth the terms and conditions for the use of this product. The installation of this product indicates that the BUYER has read and
understands this agreement and accepts its terms and conditions.

Disclaimer of Liability
StepOne Tech America Inc. and its successors, distributors, jobbers, and dealers (hereafter SELLER) shall in no way be
responsible for the product's proper use and service. THE BUYER HEREBY WAIVES ALL LIABILITY CLAIMS.
The BUYER acknowledges that he/she is not relying on the SELLER’s skill or judgment to select or furnish goods
suitable for any particular purpose and that there are no liabilities which extend beyond the description on the face
hereof and the BUYER hereby waives all remedies or liabilities, expressed or implied, arising by law or otherwise,
(including without any obligations of the SELLER with respect to fitness, merchantability and consequential damages)
or whether or not occasioned by the SELLER's negligence.
The SELLER disclaims any warranty and expressly disclaims any liability for personal injury or damages. The BUYER
acknowledges and agrees that the disclaimer of any liability for personal injury is a material term for this agreement
and the BUYER agrees to indemnify the SELLER and to hold the SELLER harmless from any claim related to the item
of the equipment purchased. Under no circumstances will the SELLER be liable for any damages or expenses by
reason of use or sale of any such equipment.
The SELLER assumes no liability regarding the improper installation or misapplication of its products.
It is the installer's responsibility to check for proper installation and if in doubt, contact the manufacturer.

Limitation of Warranty
StepOne Tech America Inc. (hereafter "SELLER") gives Limited Warranty as to description, quality, merchantability, fitness for
any product’s purpose, productiveness, or any other matter of SELLER's product sold herewith. The SELLER shall be
in no way responsible for the product’s open use and service and the BUYER hereby waives all rights other than those
expressly written herein. This Warranty shall not be extended or varied except by a written instrument signed by
SELLER and BUYER.
The Warranty is Limited to one (1) year from the date of sale and limited solely to the parts contained within the
product's kit. All products that are in question of Warranty must be returned shipping prepaid to the SELLER and must
be accompanied by a dated proof of purchase receipt. All Warranty claims are subject to approval by StepOne Tech America Inc.
Under no circumstances shall the SELLER be liable for any labor charged or travel time incurred in diagnosis for
defects, removal, or reinstallation of this product, or any other contingent expenses.
Under no circumstances will the SELLER be liable for any damage or expenses insured by reason of the use or sale of
any such equipment.
IN THE EVENT THAT THE BUYER DOES NOT AGREE WITH THIS AGREEMENT: THE BUYER MAY PROMPTLY RETURN THIS PRODUCT, IN A NEW
AND UNUSED CONDITION, WITH A DATED PROOF OF PURCHASE, TO THE PLACE OF PURCHASE WITHIN SIXTY (60) DAYS FROM DATE OF
PURCHASE FOR A FULL REFUND.
THE INSTALLATION OF THIS PRODUCT INDICATES THAT THE BUYER HAS READ AND UNDERSTANDS THIS AGREEMENT AND ACCEPTS ITS
TERMS AND CONDITIONS.
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1. General
The eFlexTuner software makes it easy to customize or reset the factory default settings for eFlexPlus and
eFlexPro products. Of course, the eFlexPlus and eFlexPro control units are ready for use out of the box with
default settings.
The eFlexTuner adjustment program can adjust the fuel supply, which affects the fuel mixture of the engine.
Adjustments can be made for enrichment of the mixture at startup and during driving.
The eFlexTuner adjustment program can adjust your engine’s fuel mixture in real time, making it easy to
monitor the effect. Adjustments can be made on the dynamometer or during normal driving.
To find the optimal adjustments, you can use the fuel content settings (Short term fuel trim and Long term
fuel trim) on the vehicle's OBD bus. For best results, we recommend that you always use a separate
broadband lambda sensor to monitor the engine’s fuel mixture.

NOTE :
The eFlexTuner adjustment software cannot be used with the eFlexEco control unit.

ATTENTION!
The eFlexFuel manufacturer is not responsible for engine damage caused by user adjustments.

Compatible eFlexFuel products
The eFlexTuner software supports the following eFlexFuel products:



eFlexPlus
eFlexPro

Computer hardware requirements
Operating system:
Bluetooth connection:
Screen resolution:

Microsoft Windows 10 (32/64 bit)
Bluetooth 4.0 (Bluetooth Smart, BLE)
At least 1280×960 (4:3), 1600x900 (16:9), 1440×900 (16:10)

Bluetooth connection
The software is connected to the eFlexPlus/Pro control unit via Bluetooth 4.0.
Most laptops have Bluetooth 4.0 capability. If you use a desktop computer, you can purchase a Bluetooth 4.0
dongle adapter.
Bluetooth 4.0 has been tested to work with at least the following adapters:
ASUS USB-BT400

Fuj:tech BT402B

TP-Link UB400
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2. Installing and launching the software


Download the compressed file with the software to your
computer from the manufacturer's website.



Extract the Zip file to the desired location on your
computer. This is also the installation folder of the
program.



Open the folder you extracted and start the program
"eFlexTuner.exe".

NOTE!



The latest software version may differ from the software version shown in the examples.
In some cases, Windows requires a special authorization to run the program. You need to accept this program run.
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3. eFlexTuner user interface
1.

Title bar

StepOne Tech Oy

1
2

3

4
2.

Menu Bar

3.

Function buttons

4.

Overview of gauges (meters)

5.

Left pane view

6.

Right pane view

7.

Status bar
5

11

7
6

More detailed descriptions of the content can be found on the following pages.
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Title bar
The title bar displays the name of the project file opened in the control program:



The project file extension is .efp.
If changes have been made to the project, a "*" character is displayed after the file name.

Menu bar
The menu bar contains all the tools you need to use the control program:

File →
New project
Open project

Create a new project file.
Open an existing project file.

Save project

Save the changes in the current project file.

Save project as ...

Save a new project file.

Exit

Close the control program.

Page25
PageError!
Bookmark not
defined.
PageError!
Bookmark not
defined.
PageError!
Bookmark not
defined.
-

Tools →
Settings

Open the setup window of the installation program.

Sensor editor

Open the sensor editor.

PageError!
Bookmark not
defined.
Page18

Device →
Connect...
Disconnect
eFlexPlus
eFlexPro
Read active tune

Open the Bluetooth pairing window.
Disconnect the Bluetooth connection to the control unit.
Change the view to the eFlexPlus version.
Change the view to the eFlexPro version.
Read the stored settings of the control unit for the control program project.

Write active tune

Write the project settings of the control program into the memory of the control unit.

Read permanent tune

Read the long-term memory settings of the control unit for a control program project.

Write permanent tune

Write the project settings of the switching program into the long-term memory of the
control unit.

Unlock tune ...

Deactivate the password lock of the control unit.

Toggle tune lock ...
Change password ...

Activate/deactivate the password lock of the control unit.
Change the password of the control unit.

Reset factory tune

Restore the control unit to factory settings.
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PageError!
Bookmark not
defined.
PageError!
Bookmark not
defined.
PageError!
Bookmark not
defined.
PageError!
Bookmark not
defined.
Page Error!
Bookmark not
defined.
Page 29
Page Error!
Bookmark not
defined.
Page Error!
Bookmark not
defined.
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Help →
About

Open the control program version information window.
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Function buttons
The most commonly used tools in the control program have their own function buttons:

Button Overview
Connect Bluetooth

 Opens the Bluetooth connection window (page 9).
 Can only be used Bluetooth is not already connected.

Disconnect Bluetooth

 Disconnects the Bluetooth connection to the control unit.
 Can only be used when the Bluetooth connection is active.

 Settings Opens the configuration window (page 13).

Sensor editor

 Opens the sensor editing program (page18).
 Creates sensor files that can only be used with eFlexPro.

Read active tune - Reads the execution memory of the control unit

 Reads the active memory parameters from the control unit for the control program project
(pageError! Bookmark not defined.).
 Can only be used when the Bluetooth connection to the control unit is active.

Write active tune to the runtime memory of the control unit

 Writes the project parameters of the switching program into the integrated memory of the
control unit (pageError! Bookmark not defined.).
 Can only be used when the Bluetooth connection to the control unit is active.

Read permanent tune - Reads the long-term memory of the control unit

 Reads the control unit's long-term memory parameters for the control program (pageError!
Bookmark not defined.).
 The active memory of the control unit is updated with the same long-term memory parameters.
 Can only be used when the Bluetooth connection to the control unit is active.

Write permanent tune to the control unit's long-term memory

 Writes the project parameters of the switching program into the long-term memory of the
control unit (pageError! Bookmark not defined.).
 The project parameters are simultaneously written to the memory of the control unit.
 Can only be used when the Bluetooth connection to the control unit is actve.
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Gauge overview
The gauge overview is located at the top of the control program window:

The gauge view displays the operating parameters of the eFlexPlus/Pro control units.
The operating parameters appear on the counters when:



Bluetooth is connected
A log file is displayed

See page 14 for instructions on displaying different gauges.
See page 92 for all types of gauges.

Left pane view
In the left pane of the control program, you will find all the fuel cards and fuel nozzle settings required to
control the eFlexPlus/Pro control units.

Contents of the tabs :
Fuel maps

eFlexPlus
 RPM Enrichment Map (page44)
eFlexPro
 Charge Enrichment Map (page52)
 Sensor Enrichment Map (page63)

Compensation

 Basic Enrichment Map (page37)

Startup crank

 Phase 1 Startup Improvement Control Cards (page77)

Startup crank hold

 Phase 2 Startup Improvement Control Cards (page77)

Startup warmup

 Phase 3 Startup Improvement Control Cards (page78)
 Phase 4 Startup Improvement Control Cards (page78)

Injectors

 Fuel injector parameters (page81)
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Right pane view
The right pane of the program includes 3D fuel maps, status information and error codes of the eFlexPlus/Pro
control units, a log window, and a log analysis tool for the eFlexPro control unit.

Content of the tabs:
3D maps

 3D representation of fuel maps (page 82).

Status

 Monitoring the status of the control unit (page 81)

Fault codes

 Reading and resetting control unit error codes (page 80)

Log

 Journal (Log) (page 83).

Log analyzer

 Log analysis tool (page88). This is only displayed with the eFlexPro control unit.

Status bar
The status bar at the bottom of the control program displays:


The Bluetooth connection status, which indicates whether the control unit is connected to the eFlexPlus/Pro control unit (1).
Not connected: No connection.
Connected:
Bluetooth is connected. When data is transferred, the background color is green.



The firmware version of the connected control unit (Firmware) (2).
(Your software version may differ.)



Shows the software version (3).

1

3

2

10

eFlexTuner User Guide

StepOne Tech Oy

4. Bluetooth: connecting the control unit
The eFlexPlus/Pro control unit must be installed in the car and paired with your computer to establish a
Bluetooth connection:



Start the engine.



Click Windows Start → Settings:



In the Settings window, click the Devices icon:



Activate Bluetooth (switch On):



When Bluetooth is active, click the Add Bluetooth or other device
button:

11
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In the window that opens, select Bluetooth:



Select "eFlexFuel" from the list. If the unit does not appear in the list, make sure
the engine is running:



When the control unit is connected to the computer, click Done:
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5. Bluetooth: Connection to the control unit
The eFlexPlus/Pro control unit must be paired with your computer before connecting (see page 9).


Start the car’s engine.



Start the eFlexTuner adjustment program.



Select Device → Login from the control bar menu bar or click the action button



In the window that opens, select "eFlexFuel”:



Click Connect:



The first time you connect, Windows may ask for permission to make a Bluetooth connection. Click
on the opening notification:



Click Allow to pair:



When permission is granted, click Close to close the window:

Continued on the next page...
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If Windows has asked for permission to make a Bluetooth connection, the setup program will display an
error message ("Receiving device version failed! Disconnecting..."):
This is normal because the control program has connected to the control unit and has not received the
model information of the device.
Click OK to close the error message. Log in again.



When connected, the control program asks whether data from the internal memory of the control
unit should be read from the draft control program:


If you have made changes to the project file of the current control program, be sure to
save the changes before reading the control unit commands! To save a project file, see
page 24.
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6. Configuration window
To open the configuration window, select Tools → Se ngs from the menu bar of the configuration program,
or click the action button

.

These icons tell you where to save the setting:
When the Bluetooth connection is open, the setting is written to the control unit and
applied immediately. To store this parameter in the long-term memory of the control
unit, select it separately from the menu bar.
Device → Write permanent tune.
This parameter is stored in the project file of the program.
This setting will not be saved. It is valid as long as the program is open.

Inputs tab
RPM calculation mode
The eFlexPlus/Pro control unit determines the RPM level based on the
synchronization of the injection pulses. Select the mode that gives the right
configuration for your car:
Mode 1 (default)

Basic setting. The engine control unit gives the injection
pulse every second engine revolution.

Mode 2

The engine control system gives an injection pulse at
each engine revolution.

Mode 3

The engine control unit delivers two injection pulses per
engine revolution.

Mode 4

The engine control system gives an injection pulse
every third revolution of the engine.

The Sensors tab
On the Sensors tab, you can select sensor files for engine sensors
connected to the analog inputs of the eFlexPro control unit.


The drop-down menus display the sensor files in the subfolder ... \ Sensors
sensors from the control program.

Analog input 1


Sensor file of the sensor connected to analog input 1 of the eFlexPro control
unit.

Analog input 2


Sensor file of the sensor connected to analog input 2 of the eFlexPro control
unit.

To create sensor files using the Sensor Editor, see page 16.
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Tune information tab
In the Tune information tab you can add data of the target car and
the creator of the modifications.

View selection tab
The View selection tab allows you to select gauge types in the
gauge view of the inspection program.


The eFlexPlus and eFlexPro control units have a variety of meter types to
choose from.

All gauge types are described in chapter 24.

Visual tab
In the Visual tab you can customize the control program’s colors.

Log tab
On the Log tab, you can select the operating parameters displayed
on the control panel's log screen.


The eFlexPlus and eFlexPro control units have a variety of operating
parameters to choose from.



The noise of the analog inputs can be filtered out. Select "Filter analog inputs"
(1). This makes it easier to identify the true values of the input sensor.

16
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Log analyzer tab (eFlexPro)
On the Log Analyzer tab, you can select the operating parameters to be used for different axes in control
program’s Log Analyzer.


Select the desired operating parameters for the x, y and z axes (1).



Define the minimum and maximum axis values starting from the "Raw value
range" (2).



The "Real value range" section (3) displays actual values corresponding to the
defined minimum and maximum axes . These values facilitate scaling of the
axis.



Analog input interference can be filtered out by selecting "Filter analog
inputs" (4).



To display only the log analysis window in the log analysis tool view,
select "Link to log view" (5). If this option is not selected, you can freely
choose the time interval to be displayed in the log.

2
1

4

5

The log analysis tool is explained in Chapter 23.
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7. Sensor Editor (eFlexPro)
Sensor files can be created using the Sensor Editor. The sensor file contains information on how to convert the
voltage of the sensor connected to the eFlexPro control unit to the actual sensor value:
Sensor

Voltage

Sensor file

Actual value

2,80 V

0.75 Bar

Open sensor editor


Select Tools → Sensor editor from the menu bar of the control panel or click the action button

.

Sensor file properties



The sensor file has the file extension .efs
The default location of the sensor files on the computer is in a subfolder ...\Sensors.
The tuner only uses the sensor files in this folder!

Elements of the sensor editor
1.

Title bar

1
2

 Displays the name of the open sensor file.
 If the sensor file has been modified, the file name is
followed by an asterisk (*).
2.





3.

3

Menu bar (Files→)

5

New sensor: Creates a new sensor file.
Open sensor: Opens a sensor file.
Save sensor: Saves changes to the open sensor file.
Save sensor as...: Saves the open sensor file to a new
sensor file.

4

Sensor info (Information)





Name: Name of the sensor chosen by you.
Manufacturer: Sensor manufacturer.
Part number: Part number of the sensor.
Unit: Measurement units (example: Bar, kPa, g/s, Psi,
AFR).
 Accuracy: Accuracy of the measured value.
 Curve type: Selection of the curve input method.
4.

Display of the operating curve (Visualization)
 Displays the operating curve of the sensor as a function
of the voltage.

5.

Entering function points - Curve (interpolation)

6

 This is active if the input mode of the sensor curve type is
set to "Interpolation".
6.

Input of the sensor function - Curve (function)
This is active if the input mode of the sensor curve type is set
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to "Function".

Creating a sensor file using a nominal voltage table
We recommend that you use the engine sensor data
sheet to create the sensor file.
1

For example, here is the data sheet of the AEM
pressure sensor #30-2130-75:


2

The sensor data sheet shows the sensor voltage curve (1)
and the table of nominal voltages (2).

Creating a sensor file


Create a new sensor file by selecting File → New sensor
from the Menu bar



Enter the sensor information in the field "Information" (3).



Select the input method "Interpolation" (4), with which the
operating points of the sensor can be copied from the
voltage value table in the sensor data sheet (2).



The operating points of the sensor are
entered in "Curve (interpolation)"(5).



Find the first operating point of the sensor in the voltage
table of the data sheet (6):
Voltage
0,5 V

5

3

4

6

Value
0.000 kPa



Enter the Voltage raw value (7), which is as close as
possible to the operating point voltage of 0.5 V (8).



Enter the Sensor value (9), which is 0.000 kPa.



To save the new action point, click (Set).

7

Continued on the next page...
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Find the other operating point of the sensor in the voltage
table of the data sheet (10):
Voltage
4,5 V

10

Measured value
515.754 kPa



Enter the Voltage raw value (11), which is as close as
possible to the operating point voltage of 4.5 V (12).



Enter the Sensor value (13), which is 515.754 kPa.



To save, click (Set).

11

12

13

When the sensor file is ready


The sensor operating points entered appear in the list (14).



The sensor curve is plotted in the Visualization graph (15).



To remove incorrectly entered sensor action points, click on
the Remove button for each row (16).

14

15

Record sensor data


From the Menu bar, choose File → Save sensor.



Make sure that the recording folder is a subfolder of the
setup program ...\Sensors.



Assign a custom name to the sensor file.



Click Save to save the sensor file.



See page 13 to connect the sensor file to the analog input
of the control unit.
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Creating a sensor file using the voltage function
1

We recommend that you use the engine sensor data
sheet to create the sensor file.

1

In this example, we create a sensor file for the AEM
X-Series UEGO 30-0300 broadband lambda sensor:


2

The sensor data sheet shows the sensor voltage function
(Formula) (1).

Creating a sensor file


Create a new sensor file. In the menu bar, select File →
New sensor.



Enter the sensor information in the "Information" field (2).



Select the input method "Function" (3) to copy the
variables of the sensor voltage function from the sensor
data table (1).





2

3

The values of the sensor voltage function
are entered in "Curve (function)" (4).

4

5

Look for the variables of the voltage function in the data
sheet table (5):
(2.3750 * volt) + 7.3125 = AFR



For example, a voltage of 2.5 V produces this result:
(2.3750 * 2.5 V) + 7.3125 = 13.25 AFR



Enter the value of variable 2.3750 to "e" (6).



Enter the value of variable 7.3125 at "f" (7).

6
7
Continued on the next page...
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When the sensor file is ready


The variables of the input voltage function are displayed
in the control cells (8).



The sensor curve is plotted in the Visualization graph (9).

8
9

Saving the sensor file


From the menu, choose File → Save sensor.



Make sure that the recording folder is a subfolder of the
setup program ...\Sensors.



Assign a custom name to the sensor file.



Click Save to save the sensor file).



See page 13 to connect the sensor file to the analog input
of the control unit.
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Creation of a sensor file without precise sensor information
A sensor file can also be created from a sensor for which no data sheet is available. In this example, we create
a new sensor file for the Throttle Position Sensor (TPS), which does not provide the exact information provided
by the manufacturer.

NOTE!
If you create the sensor file as shown in this example, note that the eFlexPro control unit must be powered on.
For some vehicles, this may require the engine to be running, also when entering action points.

Preparations


Connect the sensor to the analog input cable of the eFlexPro control unit wiring harness. In this example, the sensor is connected to
input 1.



Turn on the car’s ignition switch (current), but do not start the engine!



Connect the adjustment program to the eFlexPro control unit.

How to create the sensor file


Open the Sensor editor.



To create a new sensor file, select File → New
sensor from the menu bar.



Enter the sensor data in "Information" (1).

2

 Enter at least Name and Units.



Select the input method "Interpolation" (2) so that the
operating points of the sensor can be generated according
to the voltage of the sensor connected to the analogue
input.



The operating points of the sensor are
entered in "Curve (interpolation)" (3) .

3

1

Entering action points

4

Power is supplied to two sensor operating points:
the first point of action is taken with the throttle
fully closed and the second with the throttle fully
open.


Select to read analog input 1 (4). The sensor editor now
continuously reads the voltage of the sensor connected
to analog input 1 and displays it on the display (5).



Do not touch the accelerator when supplying the first
operating point.



Set the throttle valve position to 0% (6).



Set the first action point by clicking on "Set".

5

Continued on the next page...
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Now open the throttle fully. The new voltage value for
analog input 1 appears in the display (7).



Set the throttle valve position to 100% (8).



Set another action point by clicking on "Set".

StepOne Tech Oy

7

8

When the sensor file is ready


The entered sensor operating points appear in the list (9).



The sensor curve is plotted in the Visualization graph (11).



To remove incorrectly entered sensor action points, click on
the (Remove) button for each row (10).

10

9

8
9
11

Recording of sensor data


From the menu, choose File → Save sensor.



Make sure that the recording folder is a subfolder of the
setup program ...\Sensors.



Assign a custom name to the sensor file.



Click Save to save the sensor file.



See page 13 to connect the sensor file to the analog input
of the control unit.
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8. Project files (eFlexPlus & eFlexPro)
The project file stores the fuel maps and other settings of the eFlexPlus/Pro control unit of your car. It also
remembers the engine sensors you connected to the analog inputs of the eFlexPro control unit and records
changes made to the layout and window settings in the layout program log.
You can open and edit project files without having to connect the control program to the control unit via
Bluetooth. You can also share project files with other eFlexPlus/Pro users.

The saved project file includes:



all settings of the eFlexPlus/Pro control unit
installation program settings

Project file properties:



The extension of the project file is .efp
The default location of the computer is in a sub-folder of the setup program ...\Projects

If you have saved the settings of the eFlexPlus/Pro control unit in your car in a project file, we recommend that
you always open the project file before connecting it to the driver unit. This way, your project file is always up
to date and the layout of the control program is defined according to your preferences.

Creating a new project file
Select a control program from the menu bar to create a new project file File → New project. The new project
file must be initialized with the current settings of the control unit:




Connect the adjustment program to the control unit. From the menu bar, select Device → Connect.
The program asks whether the settings are read from the integrated memory of the control unit. Select Yes.
It makes sense to save the project file as soon as the settings of the controller are loaded. From the menu bar, select File → Save
project as ...

Creating a new project file does not change the settings on the control unit, even if the Bluetooth connection
to the control unit is active. This prevents the settings of the control unit from being changed accidentally.
If you accidentally created a new file:


Click on the menu bar to open the old project file File → Open project ... and select the parameters of the
control unit by selecting from the menu bar Device → Read active tune.



If you do not have an old project file, select the controller settings for an open project by selecting from the
menu bar Device → Read active tune.

Open a project file
To open a saved project file, select the control program File → Open project ... from the menu bar.
Opening a project file does not change the Control Unit settings even if the Control Unit has a Bluetooth
connection. This prevents the settings of the control unit from being changed accidentally.


To write the settings of an open project file to the onboard memory of the control unit, select Device
→ Write active tune from the menu bar.



If you want to write the settings of the open project file to the long-term memory of the control
unit, select Device → Write permanent tune from the menu bar.



If you want to read the controller settings from the open project file, select Device → Read active
tune from the menu bar.
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See page 25 for more information on controlling the settings of the control unit.

Saving a project file
 Select File → Save project from the menu bar to save the changes to the current project file.

 Select File → Save project As ... from the menu bar to save the current project to a new project file.
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9. Control unit settings (eFlexPlus & eFlexPro)
Control unit settings can only be read and written if there is an active Bluetooth connection to the control unit.
The eFlexPlus/Pro control unit has two memory areas:

Active memory


If the control unit is connected to the control unit via Bluetooth, all settings made in the control unit will automatically be written to
the control unit's integrated memory. This allows you to modify and experiment with adjustments in real time.



The settings in the active memory will be lost when the control unit is switched off. If you want the settings to remain on the control
unit after power down, then also store the settings in the long-term memory of the control unit.

Long-term memory


The commands in the long-term memory of the control unit are applied when the control unit is started. The parameters from the
long-term memory are then automatically transferred to the active memory of the control unit.



Always store your settings in the control unit's long-term memory to retain them even after the power is turned off.

Reading the active memory
You can read the commands in the active memory of the control unit for a control program project by
selecting Device → Read active tune from the menu bar, or by clicking the button

.

Usually the active memory is only needed to ensure that all settings of a project file opened in the control
program are in the same state as the control unit.
The setting program ensures that the settings are read:



Read the settings by clicking OK.
Click Cancel to cancel reading the settings.

Writing the active memory
You can write the settings of the project file open in the control program to the active memory of the control
unit via Device → Write active tune from the menu bar, or by clicking the button

.

As a rule, writing the active memory is necessary to ensure that the controls in the control unit are in the same
state as the project file opened in the control program. You can also use active memory writing when you
open a new project file and want to send all its settings to the control unit for testing. The settings in the builtin memory will be lost when the control unit is switched off.
The adjustment program ensures that settings are written:



Write the settings by clicking OK.
Click Cancel to cancel writing the settings.

27

eFlexTuner User Guide

StepOne Tech Oy

Long-term memory reading
You can read the long-term memory settings of the control unit for a control program project by selecting
Device → Read permanent tune from the menu bar or by clicking the button

.

Reading the long-term memory is usually necessary when new control mode settings have been tried on the
control unit and it is desirable to restore the previous long-term controls of the control unit.
When the long-term memory is read out, its settings are transferred to the open project file of the control
program and to the active memory of the control unit.
The setting program ensures that the settings are read:



Read the settings by clicking OK.
Click Cancel to cancel reading the settings.

Writing long-term memory
You can read the commands in the active memory of the control unit for a control program project by selecting
Device → Read permanent tune from the menu bar, or by clicking the button

.

Long-term memory writing is used to permanently record completed and functional adjustments to a project
file currently open in the control program. Adjustments written to long-term memory remain in the memory of
the control unit even after power down. Adjustments written to long-term memory are also written to the
control unit's current memory.
The setting program ensures that the readings are written:



Write the settings to long-term memory by clicking OK.
Click Cancel to cancel writing the settings.

Restore factory settings
The commands in the control unit memory can be reset to factory settings by selecting Device → Reset factory
settings from the menu bar.
Restoring the factory settings will erase all settings made by the user in the memory of the control unit.
Resetting does not erase long-term memory adjustments, so accidental adjustments will not be lost.
If you want to also save the factory settings in the long-term memory of the control unit, you must do this
after the restoration by selecting Device → Write permanent tune from the menu bar.
The setting program ensures that the factory settings are reset to the default
values:



Reset to factory settings by clicking OK.
Click Cancel to cancel the factory reset.
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Password lock (eFlexPlus & eFlexPro)

The eFlexPlus/Pro control unit can be locked with a password. This prevents parameters from being displayed,
changed or copied.

NOTE!
The mobile application works normally even if the settings on the control unit are locked with a password. The
password lock only prevents the display of parameters related to your own settings.
The default password for the control unit is 1234.

Opening the password lock
When the control program is connected to the control unit locked by password, a
message is displayed:


Close the message by clicking OK.



In the menu bar, choose Device → Unlock tune... The software shows the window:



Fill in the password and click OK.



If the password you entered was incorrect, a message will be displayed:



Close the message by clicking OK.



Re-enter the password by selecting from the Device menu bar → Unlock tune...



If you enter your password incorrectly three times, you will not be able to unlock it and a
message will appear:



Close the message by clicking OK.



The password lock can only be reopened after the engine has been restarted!



When the password was correct, a message will be displayed:



Close the message by clicking OK.



The adjustment program will continue to connect normally ...
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Activating and deactivating the lock
The password lock of the control unit can be activated or deactivated by selecting from the menu bar
Device → Toggle tune lock...



The program displays the window:



Enter the current password in "Password".




To enable password locking, select the "Lock tune using password" item.



Click OK to edit. Click Cancel to cancel it.



If the password you entered was incorrect, a message will be displayed:



Close the message by clicking OK.



In the menu bar, choose Device → Toggle tune lock again.



If the password is entered incorrectly three times, it will no longer be possible to activate or
deactivate the password lock and a message will be displayed:



Close the message by clicking OK.



The password lock can only be reopened after the engine has been restarted!



When the password was correct, a message will be displayed:



The password protection is now in the mode you selected.



Close the message by clicking OK.

To disable the lock, uncheck "Lock tune using password".
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Change Password
The password of the control unit can be changed by selecting from the menu bar Device → Change
password...



The program displays the window:



Enter the old password in "Old password".



Enter the new password in "New password".



Enter the new password again in "Retype new password".



Change the password by clicking OK. Cancel the action by clicking Cancel.



When the old password was correct, a message will be displayed:



Close the message by clicking OK.



In the menu bar choose Device → Change password... again.



If the password is entered incorrectly three times, it will no longer be possible to activate or
deactivate the password lock and a message will be displayed:



Close the message by clicking OK.



The password lock can only be reopened after the engine has been restarted!



When the old password was correct, a message will be displayed:



The password has been changed.



Close the message by clicking OK.
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Use of engine sensors (eFlexPro)

The eFlexPro control unit is equipped with two analog inputs. Voltage level sensors measuring engine activity
can be connected:



The allowed voltage range for the analog input is 0 - 5V.
Frequency output sensors cannot be connected to the analog input (PWM).

ATTENTION!
If the analog inputs of the control unit are supplied with a voltage outside the allowed voltage range, the
control unit may be damaged! Always make sure that the output voltage of the sensor is within the allowed
range before connecting.

Objective of the sensors
Sensors connected to the analog inputs of the control unit can be used for precise load-dependent control of
the engine fuel supply, for monitoring engine operations, and for making safety adjustments.
There are different types of sensors:
Sensor
MAP
MAF
GST
WBO

Description
Air duct pressure sensor
Air mass flow sensor
Throttle valve position sensor
Lambda sensor with wide exhaust band (requires separate controller)

Operation with eFlexPro
Adjustment/monitoring
Adjustment-/-monitoring
Adjustment-/-monitoring
Setting (with reservation)-/-monitoring

ATTENTION!
eFlexPro does not include Wideband Lambda Sensor (WBO) control. Use an upgrade system with a ready-made
analog output. Here are a few examples of wideband sensors:




AEM X-Series Wideband UEGO
PLX SM-AFR
Innovate MTX-L Plus

Recommended use of sensors by engine type
Sensor
MAP
MAF
GST
WBO

Natural aspirated engine
OK
OK
OK
OK

Supercharged engine
OK
OK
Preferably MAP/MAF
OK

Engine cycles
Not recommended
Do not use
OK
OK




All types of sensors can be used in naturally aspirated car engines.



In case of supercharged engines, it is recommended to use the intake manifold pressure sensor (MAP) or the air mass flow meter
(MAF). The Throttle Position Sensor (TPS) may not accurately reflect the engine load.

The use of an Intake Line Pressure (MAP) sensor is not recommended for engine cycles as the sensor can display very inaccurate
information.
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Connection of sensors to the wiring harness
The eFlexPro control unit wiring harness has two analog input wires (input wire 2 is supplied separately and is
referenced on page 32). The analog input wires are connected to the voltage output side of the engine sensor.
The connection must be made carefully so that the connection of the sensor to the car's engine control unit
(ECU) is not disturbed.

NOTE!
It is recommended to use the car's electrical wiring diagram to identify the voltage output wires for the engine
sensors.

Connection example
In this example, the analog input lead 1 is connected to a MAP sensor and input lead 2 is connected to a
separate WBO sensor control unit. You can connect the analog input wires as you wish.
ECU

eFlexPro

Air duct pressure sensor MAP
Engine wiring harness :
sensor input

eFlexPro cable harnesses:
analog inputs

Analog input cable 1
Air mass flow sensor
MAF

Option
Throttle valve position sensor
TPS

Option

Wide band lambda sensor WBO

Analog input cable 2
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Connections (2) of the analog input cable to the wiring harness
The analog input cable 1 is pre-wired to the cable harness supplied with the eFlexPro control unit. The cable
for analog input 2 is supplied separately. The cable can be connected to the wiring harness as follows:
Remove terminal block end plate from the eFlexPro harness:

2
3

1

1.
2.
3.



Press the locking tab of the end plate outward
Unhook the end plate
Repeat steps 1 and 2 for the other end of the end plate.

Remove the protective plug from analog input 2:
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Plug the analog input cable 2 into the terminal block. The terminal locks down :
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Re-attach the end plate of the terminal block:
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Check the position of the terminal at the end of the cable.
The terminal only locks in this position!

eFlexTuner User Guide

12.

StepOne Tech Oy

Control unit setting menu (eFlexPlus & eFlexPro)

The eFlexPlus/Pro control unit includes 5 adjustable parameters. The adjustments may affect the engine fuel
mixture. Please note that the control unit has built-in factory default settings that allow you to operate the
equipment safely without the need for adjustments. The control unit can easily be reset to factory settings if
necessary. The table below lists the adjustable parameters for the different device models:
Basic enrichment:
Enrichment of RPMs:
Charge enrichment:
Enrichment of the sensor:
Enrichment of start up:

eFlexPlus



eFlexPro







Adjustable parameters
The eFlexPlus/Pro control unit contains customizable control maps. The control maps can be used to influence
the engine fuel mixture. The adjustable maps are shown below:

Assigned
values

Customizable
cards

% ethanol in fuel

Basic Enrichment Map
(page 38)

RPM level

RPM Enrichment Map
(page 45)

RPM level

Fixed cards

eFlexPlus/Probasic enrichment

Load Enrichment Card
(page 53)

Engine Sensors

Engine Sensors

Engine
Temperature
% ethanol in fuel

Sensor Enrichment Card
(page 64)

Enrichment Startup
Map
(page72)

eFlexPlus/Pro cold start
base map

Final Enrichment
in %

The eFlexPlus/Pro control unit calculates the final enrichment percentage based on the factory default settings
and changes made by the user. Each adjustment card affects the final enrichment.
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Basic enrichment (eFlexPlus & eFlexPro)

The eFlexPlus/Pro control unit determines the ethanol content of the fuel with an ethanol sensor. Based on
the ethanol content, the control unit calculates the base enrichment content required to run the engine as
accurately as possible with the correct fuel mixture. The amount of base enrichment can be adjusted when
needed:

% ethanol in fuel

eFlexPlus/Pro-

Basic Enrichment Map
(editable)

basic enrichment

Modified
enrichment in %.

NOTE!
Changes to the Base Enrichment Control Card will only affect the fuel supply if you have filled up with ethanol.
We recommend only changing the basic enrichment level for ethanol contents above 30%.

ATTENTION!
Excessive reduction of the basic enrichment control card may result in an excessively lean fuel mixture. A fuel
mixture that is too lean can permanently damage the engine*. Avoid large value changes! Make minor
changes and check the fuel mixture change before the next adjustment. We recommend that you always use a
broadband lambda sensor to monitor the fuel mixture.

* The use of this product indicates that the BUYER has read and understands the “disclaimer of
liability” agreement contained in this document and accepts its terms and conditions.
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Basic Enrichment Control Chart
The basic enrichment control chart can be found on the Compensation tab:

2

3
The top row of the map, EC%, shows the percentages of fuel ethanol (2). The ethanol content is freely
changeable:



Adjustment range 0 - 100%.
Setting accuracy 1%.

The adjustment values, Corr %, can be found on the lower row of the map (3). The adjustment values change
the percentage of base enrichment relative to the ethanol content on the top row of the map:






Adjustment range 0 - 255
100%, the default value which defines the enrichment according to the factory settings eFlexPlus/Pro
< 100%, decreases enrichment
> 100%, increases enrichment
0%, no enrichment

Effect of control values on enrichment
The values defined in the basic enrichment control chart affect enrichment as follows, with 30% ethanol
content given as an example:

Base value:
Minimum ethanol content *:
Adjustment value:
Modified enrichment:

30,0%
100%
30,0 * 100% = 30,0%

Increase enrichment:
Minimum ethanol content *:
Adjustment value:
Modified enrichment:

30,0%
120%
30,0 * 120% = 36,0%

Decrease enrichment:
Minimum ethanol content *:
Adjustment value:
Modified enrichment:

30,0%
75%
30,0 * 75% = 22,5%

The eFlexPlus/Pro control unit calculates the basic enrichment based on the ethanol content of the fuel.
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Changing the ethanol content
Click on the basic enrichment control chart as seen below:

This opens the ethanol content editor:
1

2

- Set the desired ethanol contents from the setting screens in the upper row (1).
- If you have made changes to the map setting values, make sure Interpolate map (2) is selected. Thus, the control values are automatically
calculated based on the new ethanol contents.
- Click OK to set the new values. If you want to cancel your changes, click Cancel.

NOTE!
Changes in ethanol contents are immediately stored in the memory of the control unit if a Bluetooth connection
is active.
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Tools menu of the settings
The tool menu is opened by right-clicking on the selected setting values. The tools affect the selected cells on
the map. You can select several cells at a time by holding down the left mouse button.

NOTE!
Changes made to the control card are immediately written to the memory of the control unit when the
Bluetooth connection is active.

Descriptions of the tools menu:

Set



Opens the parameter window Set value
Defines the value given for all selected control chart
cells (here, for example, 120%).

Change



Opens the Change value parameters window



Calculation example: 100 - 10 = 90%.

Changes the value of all selected control chart cells to
the given value (here for example -10).

Multiply



Opens the Multiply value parameters window



Calculation example: 100 * 1.25 = 125%.

Changes the value of all selected control chart cells by
a given factor (here for example 1.25).

Zero correction


Sets the value to 100% for all selected control chart
cells
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At 100%, the basic enrichment is calculated based on the ethanol content of the fuel only (no correction of its own).

Interpolate
Interpolate automatically calculates and completes the values between the selected control chart cells.
In this example, the following changes have been made to the control chart:



With an ethanol content of 30%, a target value of 80% is defined (diluting the mixture).
80% ethanol has a target value of 120% (enriching the mixture)

Chart cells between 30 and 80% ethanol content always have constant values of 100%. Their setting values can
be automatically adjusted so that the change between 80 and 120% is as smooth as possible.



On the control board, select 30 - 80% ethanol content cells by holding the left mouse button and dragging:



When the cells are selected, the Interpolate tool is used:

As a result, the ethanol content range of 30 to 80% is automatically extended so that the adjustment values
between them change gradually from 80% to 120%.

Effect of modified values at different ethanol contents
The figure shows an example of a map with adjustments for ethanol contents of 30 to 85%:


At ethanol contents of 60, 65 and 70%, the fuel blend is adjusted to be richer (> 100%).
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With an 85% ethanol content, the fuel blend is adjusted to a lower level (<100%).

The values defined on the map are used with the corresponding fuel ethanol contents. Between the defined
ethanol contents, the eFlexPlus/Pro control unit calculates the control value to be used based on the control
values on the adjacent cells.
The examples of map fit values affect different ethanol contents as shown in the following graph (the exact
map fit values are marked on the graph as dots):

NOTE!
If the ethanol content of the fuel is lower or higher than the ethanol content values seen on the chart, then the
outermost value of the chart will be used.
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Recommendations for adjustment of base enrichment
It's worth focusing on basic enrichment if:



The fuel mixture requires the same amount of correction over the entire RPM level range.
The correction value LONG TERM FUEL TRIM* for engine fuel map control deviates from 0%.

Value LONG TERM FUEL TRIM:
0%
< 0%
> 0%

No need to correct.
Correct the adjustment to a leaner level relative to the current ethanol content.
Correct the adjustment to a richer level compared to the current ethanol content.

NOTE!
Always adjust the base enrichment correction according to the ethanol content of the fuel.

* The LONG TERM FUEL TRIM* correction value for engine control can be read in most cars via the OBD
reader.
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RPM level enrichment (eFlexPlus)

The eFlexPlus control unit supports fuel mixture changes at different RPM levels.

Basic enrichment
in %.

Engine RPM level

RPM Enrichment Map
(modifiable)

Modified
Enrichment in %.

NOTE!
Changes to the RPM card will only affect the fuel supply if you have filled up with ethanol. Avoid adjusting
the control card if the fuel has an ethanol content of less than 30%.

ATTENTION!
Excessive revisions to the RPM card may result in fuel mixture that is too lean. A fuel mixture that is too lean
can permanently damage the engine*. Avoid changes that are too big! Make minor modifications and check
the fuel mixture change before the next adjustment. We recommend that you always use a broadband lambda
sensor to monitor the fuel mixture.

* The use of this product indicates that the BUYER has read and understands the “disclaimer of
liability” agreement contained in this document and accepts its terms and conditions.
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RPM level enrichment map
The Engine RPM Enhancement Map can be found in the Fuel maps tab (1).
This map will only be displayed if Device → eFlexPlus is selected in the control bar of the top menu bar, or if
the control program is connected to the eFlexPlus control unit:
1

2

3

The top row of the map shows the RPM levels (2). The levels are freely selectable:



Adjustment range 0 - 25500 RPM
Setting accuracy 100 RPM

The adjustment values can be found on the last row of the map (3). The adjustment values change the
enrichment percentage:






Adjustment range 0 - 255
100%, the standard value at which enrichment is determined solely by the ethanol content of the fuel
< 100%, decreases enrichment
> 100%, increases enrichment
0%, no enrichment

Effect of modified values on enrichment
The values set on the RPM level enrichment map affect the RPM as follows, with 30% ethanol content given as
an example:

Base value:
Minimum ethanol content *:
Adjustment value:
Modified enrichment:

30,0%
100%
30,0 * 100% = 30,0%

Increase enrichment:
Minimum ethanol content *:
Adjustment value:
Modified enrichment:

30,0%
120%
30 * 120% = 36,0%

Decrease enrichment:
Minimum ethanol content *:
Adjustment value:
Modified enrichment:

30,0%
75%
30 * 75% = 22,5%

The eFlexPlus control unit calculates the base enrichment based on the ethanol content of the fuel.
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RPM level changes
Click on the RPM Enhancement Map for RPM changes:

This opens the edit window:
1

2

3



Set the desired RAW values from the setting screens in the upper row (1).



The actual RPM levels corresponding to the setting values are shown below the cells (2).



If you have made changes to the RPM map values, make sure that Interpolate map (3) is selected. This will automatically adjust the
values according to the new RPMs.



Click OK to save the new values. If you want to cancel your changes, click Cancel.

NOTE!
Changes made to the RPMs are immediately written to the memory of the control unit when the Bluetooth
connection is active.
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Changes in percentage values
Use the left mouse button to select the cells in the control chart whose values you want to change. You can
select multiple cells by holding down the left mouse button and dragging.

You can change the value of the selected cells by:




pressing the plus and minus buttons on the keypad (increase and decrease), OR
typing the desired numeric values, then press ENTER, OR
using the Adjust Map Tool (see Adjust Map Tool Menu).

NOTE!
Changes made to the control card are immediately written to the memory of the control unit when the
Bluetooth connection is active.

Menu of the setting card tool
The tool menu is opened by right-clicking on the selected cells. The tools affect the selected cells on the map.
You can select multiple cells by holding down the left mouse button and dragging:

NOTE!
Changes made to the control card are immediately written to the memory of the control unit when the
Bluetooth connection is active.

Description of the tools in the Options menu:

Set



Open the parameter window Set value
Defines the value given for all selected control chart
cells (here for example 120%).

Change



Open the Change value parameters window
Changes the value of all selected control chart cells by
the given value (here for example -10)
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Calculation example: 100 - 10 = 90%.

Multiply



Open the Multiply value parameters window.



Calculation example: 100 * 1.25 = 125%.

Changes the value of all selected control chart cells by
a given factor (here for example, 1.25).

Zero correction


Sets the value of all selected control chart cells to
100%.



100% enrichment is calculated based on the ethanol
content of the fuel only (no correction of its own).

Interpolate
Interpolate automatically calculates and completes the values between the selected control chart cells.
In this example, the following changes have been made to the control chart:



RPM level of 2000 RPM set at 80% (diluting the mixture)
RPM level of 6000 RPM set at 120% (enriching the mixture)

The setting screens between 2000 and 6000 RPM always have constant values of 100%. Their setting values
can be automatically supplemented so that the transition between 80 and 120% is as smooth as possible.
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Select the engine speed cells 2000 - 6000 RPM from the control board by clicking and dragging:



When the check cells are selected, the Interpolate tool is used:
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As a result, the range between 2000 and 6000 RPM is automatically extended so that the adjustment values
between them change gradually from 80% to 120%.
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Effect of modifying values at different RPM levels
The picture shows an example of a map with adjustments from 0 - 6500 RPM:



At 2500 RPM and 3000 RPM, the fuel mixture is adjusted richer (> 100%).
At 4500 and 6500 RPM, the fuel mixture is leaner (< 100%).

The values defined on the map are used at their respective RPM levels. Between defined RPMs, the eFlexPlus
control unit calculates the setpoint to be used, based on the setpoint values on the adjacent screens.
An example of how map setting values affect the entire RPM level range is shown in the following graph (the
exact map setting values are marked by dots):

NOTE!
If the RPM level is lower or higher than the outermost values of the chart, then the outermost value of the chart
is used.
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Recommendations for enrichment adjustment
It's worth focusing on basic enrichment if:



the fuel mixture requires the same amount of correction over the entire RPM level range.
the SHORT TERM FUEL TRIM* correction value for engine control deviates from 0%.

For example, you can use the SHORT TERM FUEL TRIM correction value for reading the engine’s fuel map via
the vehicle's OBD bus to assist with tuning:
Value SHORT TERM FUEL TRIM:
0%
< 0%
> 0%

No need to correct.
Correct the adjustment to a leaner level relative to the current ethanol content.
Correct the adjustment to a richer level compared to the current ethanol content.

* The reading of the SHORT TERM FUEL TRIM* correction value can be done in most cars via the OBD reader.
RPM control can also be used to optimize the fuel mixture on the power dynamometer. In this case, we
recommend using a broadband lambda sensor to monitor the mixture. Adjustment can be used to find the
right fuel mixture for the best engine torque and peak power.
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Load Enrichment (eFlexPro)

The eFlexPro control unit supports fuel mixture changes based on RPM level and information from the external
engine sensor. This allows the fuel mixture to be precisely adjusted according to the engine load:

Basic enrichment
in %.
RPM level

Sensor data

Charge Enrichment
Card
(modifiable)

Modified
Enrichment in %.

NOTE!
Changes to the Load Improvement Card will only affect the fuel supply if you have filled up with ethanol. Avoid
adjusting the control card if the fuel has an ethanol content of less than 30%.

ATTENTION!
Excessive adjustment to the charge enrichment card may result in an excessively lean fuel mixture. A fuel
mixture that is too lean can permanently damage the engine*. Avoid changes that are too big! Make small
changes and check the fuel mixture change before the next adjustment. We recommend that you always use a
broadband lambda sensor to monitor the fuel mixture.

* The use of this product indicates that the BUYER has read and understands the “disclaimer of
liability” agreement contained in this document and accepts its terms and conditions.
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Load Enrichment map
The load enrichment map can be found in the Fuel maps tab (1).
This card will only be displayed if Device → eFlexPro is selected in the control bar in the top menu bar, or if the
control is connected to the eFlexPro device version:
1
2

3

4

5
The top row of the map shows the RPM levels (2). The levels are freely selectable:



Adjustment range of 0 - 25500 RPM
Setting accuracy 100 RPM

On the left side of the card are the setting values (3) of the external engine sensor used to adjust the card. The
setting values are freely selectable:



Adjustment range of 0 - 255 [RAW] (corresponds to the sensor voltage range 0 - 5V)
Adjustment accuracy 1 [RAW] (corresponds to the sensor voltage range 20mV)

The adjustment values can be found on the map (4). The adjustment values change the enrichment
percentage:






Adjustment range of 0 - 255
100%, the standard value at which enrichment is determined solely by the ethanol content of the fuel
< 100%, decreases enrichment
> 100%, increases enrichment
0%, no enrichment

The analog input of the engine sensor used to adjust the charge content control is available in the pull-down
menu (5):



Analog input 1 or Analog input 2 can be selected.
Corresponds to the analog inputs of the wiring harness terminal block
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Effect of modified values on enrichment
The values set on the RPM level enrichment map affect the RPM as follows with 30% given as an example:

Base value:
Minimum ethanol content *:
Adjustment value:
Modified enrichment:

30,0%
100%
30,0 * 100% = 30,0%

Increase enrichment:
Minimum ethanol content *:
Adjustment value:
Modified enrichment:

30,0%
120%
30 * 120% = 36,0%

Decrease enrichment:
Minimum ethanol content *:
Adjustment value:
Modified enrichment:

30,0%
75%
30 * 75% = 22,5%

* Example of a value. The eFlexPlus control unit calculates the base enrichment based on the ethanol
content of the fuel.
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Changes at RPM level
Click on the RPM Enhancement Map for changes at RPM level:

This opens the edit window:
1

2

3



Set the desired RAW values from the setting screens in the upper row (1).



The actual RPM levels corresponding to the setting values are shown below the setting cells (2).



If you have made changes to the RPM scale values, make sure that Interpolate map (3) is selected. This will automatically adjust the
values according to the new RPMs.



Click OK to set the new RAW values. If you want to cancel your changes, click Cancel.

NOTE!
Changes to RPM levels are immediately written to the control unit's memory when the Bluetooth connection is
active.

55

eFlexTuner User Guide

StepOne Tech Oy

Changing the engine sensor values
Click on the Load Improvement setting chart for the engine sensor values:

This opens the window for editing the engine sensor values:


Set the desired sensor input control values from the control screens (1).



The actual sensor values corresponding to the control values are displayed next to
the control cells (2).



If you have made adjustments to the LOAD scale Map, check that the Interpolate
map (3) option is selected. This will automatically adjust the setting values
according to the new values from the engine sensor.



Click OK to set the new engine sensor values or Cancel to cancel your changes.

2

1

3

NOTE!
Using the sensor file, the engine sensor values are displayed in the
correct unit of measurement:


In this example, a pressure sensor is used which measures the pressure in the
inlet line through the unit Bar (4).

 The sensor editor is explained in more detail on page 17.
 To connect the sensor file to the analog input, see page 14.

NOTE!
Changes to the sensor setpoints are immediately written to the
memory of the control unit if the Bluetooth connection is active.
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Changing the setting values
Use the left mouse button to select the cells in the control chart whose values you want to change. You can
select multiple cells by holding down the left mouse button and dragging:

You can change the value of the selected cells by:




pressing the plus and minus buttons on the keypad (increase and decrease), OR
typing the desired value in numbers, then press ENTER, OR
using the Adjust Map Tool (see Adjust Map Tool Menu).

NOTE!
Changes made to the control card are immediately written to the memory of the control unit when the
Bluetooth connection is active.
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Tools menu of the setting card
The tool menu is opened by right-clicking the selected setting values. The value changes affect the selected
cells on the map. You can select multiple cells by holding down the left mouse button and dragging:

NOTE!
Changes made to the control card are immediately written to the memory of the control unit when the
Bluetooth connection is active.

Description of the tools menu:

Set



Open the parameter window Set value
Defines the value given for all selected control chart
cells (here for example 120%).

Change




Open the Change value parameters window
Changes the value of all selected control chart cells by
the given value (here for example -10)
Calculation example: 100 - 10 = 90%.
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Multiply




Open the Multiply value parameters window.
Changes the value of all selected control chart cells by
a given factor (here for example 1.25).
Calculation example: 100 * 1.25 = 125%.

Zero correction


Sets the value of all selected control chart cells to
100%.



100% enrichment is calculated based on the ethanol
content of the fuel only (no correction of its own).

Interpolate
Interpolate automatically calculates and completes the values between the selected control chart cells.
In this example, the following changes have been made to the control chart:




At 3000 RPM and a value of the external sensor 150 [RAW] (2.95V) the value is changed to 80% (reducing the mixture).
At 3000 RPM and a value of the external sensor 255 [RAW] (5.00V) the value is changed to 110% (enriching the mixture).
At 6000 RPM and a value of the external sensor 255 [RAW] (5.00V) the value is changed to 120% (enriching the mixture).

The cells between the adjusted adjustment values always have default values of 100%. Their adjustment
values can be calculated automatically so that the transition between the adjusted values is as smooth as
possible.
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Select the setting cells by clicking and dragging across them so that the changed values are in the corners of the selected area:



When the check cells are selected, right-click and select Interpolate:

The range between the adjusted values is automatically calculated so that the transitions between them is
gradual:
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Effect of RPM and external sensor value adjustment
The eFlexPro control unit determines the position to be read from the control panel based on the RPM level
and the value of the external sensor. The exact point used on the map is indicated in the adjustment program
with a "grid on the map".


Here is a map with an RPM level of 3800 and value of the external sensor of 195 (corresponding to 3.82V).

The eFlexPro control unit calculates the offset value to be used based on the values of the nearest grid cells.
The cells used to calculate the correction value are described in the following figure:




The values of all squares will affect the value used. The value is calculated so that there is a "smooth" transition between cells.
If the "grid" is exactly on one cell, then the value of one screen will be used in the calculation.

NOTE!
If the RPM level or engine sensor values are outside the limits of their table values, the value of the outer
column/row in the table is used.
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Recommendations for enrichment adjustment
It's worth focusing on enrichment if:




you want to optimize the engine fuel mixture at a given RPM level and sensor value
the fuel mixture requires correction over a specific RPM level range.
the SHORT TERM FUEL TRIM* correction value for engine control deviates from 0%.

For example, you can use the SHORT TERM FUEL TRIM correction value for reading the engine’s fuel supply
control via the vehicle's OBD bus to assist with tuning:
Value SHORT TERM FUEL TRIM:
0%
< 0%
> 0%

No need to correct.
Correct the adjustment to a leaner level relative to the current ethanol content.
Correct the adjustment to a richer level compared to the current ethanol content.

* The reading of the SHORT TERM FUEL TRIM* correction value for engine control can be done in most cars
via the OBD reader.
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Enrichment via sensor (eFlexPro)

The eFlexPro control unit supports fuel mixture conversion based on a single engine sensor value:

Basic enrichment
in %.

Engine sensor
data

Sensor enrichment card
(can be modified)

Modified
enrichment in %.

NOTE!
Changes to the sensor enrichment map will only affect the fuel supply if you have filled up with ethanol. Avoid
adjusting the control map if the ethanol content of the fuel is less than 30%.

ATTENTION!
Excessive adjustment to the sensor enrichment map may result in an excessively lean fuel mixture. A fuel
mixture that is too lean can permanently damage the engine*. Avoid too big changes to the base values! Make
minor changes and check the fuel mixture change before the next adjustment. We recommend that you always
use a broadband lambda sensor to monitor the fuel mixture.

* The use of this product indicates that the BUYER has read and understands the “disclaimer of
liability” agreement contained in this document and accepts its terms and conditions.
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Sensor enrichment map
The sensor enrichment map can be found in the Fuel maps tab (1). This card will only be displayed if Device →
eFlexPro is selected in the control bar in the top menu bar, or if the control is connected to the eFlexPro
control unit:
1

2

3

4

The top row of the map shows the RPM levels (2). The levels are freely selectable:



Adjustment range 0 - 25500 RPM
Setting accuracy 100 RPM

The adjustment values can be found at the bottom of the map (3). The adjustment values change the
enrichment percentages:






Adjustment range 0 - 255
100%, the standard value at which enrichment is determined solely by the ethanol content of the fuel
< 100%, decreases enrichment
> 100%, increases enrichment
0%, no enrichment

The engine sensor input used to adjust the map is available in the Analog input pull-down menu (4):



Analog input 1 or Analog input 2 can be selected.
Corresponds to the analog inputs on the terminal block of the control unit.
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Effect of control values on enrichment
The values set on the sensor enrichment control card affect enrichment as follows, with 30% given as an
example:

Base value:
Minimum ethanol content *:
Adjustment value:
Edited enrichment:

30,0%
100%
30,0 * 100 % = 30,0%

Increase enrichment:
Minimum ethanol content *:
Adjustment value:
Edited enrichment:

30,0%
120%
30 * 120% = 36,0%

Decrease enrichment:
Minimum ethanol content *:
Adjustment value:
Edited enrichment:

30,0%
75%
30 * 75% = 22,5%

The eFlexPro control unit calculates the base enrichment based on the ethanol content of the fuel.
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Changing sensor values
Click on the Sensor Enrichment Control Chart for engine sensor values:

This opens the window for editing the engine sensor values:
1

2

3





Set the desired sensor input control values from the adjustment cells in the upper row (1).



Click OK to save the new values. If you want to cancel your changes, click Cancel.

The actual sensor values corresponding to the adjustment values are displayed below the adjustment cells (2).
If you have made changes to the values on the sensor enrichment control map, make sure that the Interpolate map (3) option is
selected. This will automatically adjust the adjustment values according to the new values.

NOTE!
The engine sensor values are displayed in the correct unit of measurement using the sensor file:


This example uses a broadband lambda sensor that measures the fuel mixture on an AFR unit (4).

4
 The sensor editor is explained more in-depth in chapter 7.
 To connect a sensor file to the analog input, see page 14.

NOTE!
Changes to the sensor values are immediately written to the active memory of the control unit if the Bluetooth
connection is active.
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Change the setting values





Left-click on one of the cells on the control card whose value you want to change.
Enter the desired numeric value and press ENTER.
You can also use the tools in the control map tools menu (right click to open the menu).

Tools menu of the setting card
The tools menu is opened by right-clicking on the selected setting values. The value changes affect the
selected cells on the map. You can select multiple cells by holding down the left mouse button and dragging:

NOTE!
Changes made to the control card are immediately written to the memory of the control unit when the
Bluetooth connection is active.

Description of the tools menu:

Set



Opens the parameter window Set value
Defines the value for all selected control chart cells
(here for example 120%).

Change




Opens the parameter window Change value
Changes the value of all selected control chart cells by
the given value (here for example -10)
Calculation example: 100 - 10 = 90%.
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Multiply



Opens the Multiply value parameter window.



Calculation example: 100 * 1.25 = 125%.

Changes the value of all selected control chart cells by
a given factor (here for example 1.25).

Zero correction


Sets the value to 100% on all selected control chart
cells



100% enrichment is calculated from the ethanol
content of the fuel only (no correction of its own).

Interpolate
Interpolate automatically calculates and adjusts the values between the selected control chart cells.
In this example, the following changes have been made to the control chart:



The sensor value of 51 [RAW] (corresponding to the sensor voltage value of 1V) is set to 80% (diluting the mixture).
The sensor value 153 [RAW] (corresponding to the sensor voltage value 3V) is set to 120% (enriching the mixture).

The adjustment screens between sensor values 51 and 153 [RAW] always have standard values of 100%. Their
setting values can be automatically supplemented so that the transition between 80 and 120% is as smooth as
possible.


In the control card, select the cells for sensor values 51 to 153 [RAW] by left-clicking and dragging:



When the cells are selected, the Interpolate tool is used:

As a consequence, the range between sensor values 51 and 153 [RAW] is automatically extended so that the
adjustment values between them change gradually from 80% to 120%.
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Effect of the set values on different sensor values
The illustration shows an example with adjustments for sensor values from 0 to 255
[RAW] (corresponding to sensor voltage 0 to 5V):



At sensor values of 100 and 125 [RAW] (sensor voltages 1.96 and 2.45V), the fuel mixture is adjusted to be richer (> 100%).
At sensor values of 200 and 255 [RAW] (sensor voltages 3.92 and 5.00V), the fuel mixture is adjusted to be leaner (< 100%).

The adjustment values defined on the chart are used together with the corresponding sensor values. In the
range between the defined values, eFlexPro calculates the setpoint to be used based on the setpoints of
adjacent cells.
The example adjustment values of the chart affect the entire operating range of the sensor according to the
following graph (the exact adjustment values of the chart are marked by dots ):

NOTE!
If the sensor value is lower or higher than the sensor values of the chart, then the outermost value of the chart
is used.
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Recommendations for checking the enrichment of sensors
Here are three examples of when a sensor enhancement card can be used.

NOTE!
The examples given are only illustrative and may not work in all vehicles.
The examples use sensor files to represent the sensor value in the correct unit of measurement. The creation of
sensor files is illustrated in Chapter 7.

Fuel mixture safety adjustment




Connect the external broadband lambda sensor to the eFlexPro control unit and use it as sensor information for the enrichment card.
Select the sensor values so that you can specify additional enrichment for fuel mixtures that are too thin.
Increase enrichment to fuel mixture values that are clearly too thin.

In this example map, an enrichment fuel mixture (> 100%) with higher values of 15.1 AFR was added:

Enrichment at full throttle




Connect the engine throttle sensor to the eFlexPro control unit and use it as sensor data for the sensor enhancement card.
Select the sensor values as desired to increase the enrichment as throttle is opened more.
Increase enrichment at high throttle positions.

In this example, an enrichment (>100%) at gas positions 80-100% has been added:

Boost pressure enrichment
- Connect the engine boost pressure sensor to the eFlexPro control unit and use it as sensor data for the enrichment card.
- Select the sensor values as required to increase the enrichment at higher boost pressures.
- Increase enrichment at high boost pressures.

In this example, the enrichment has been gradually increased (> 100%) to values above 0.00 Bar:
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Startup enrichment (eFlexPlus & eFlexPro)

In colder conditions, ethanol fuel requires more enrichment when starting the engine . The eFlexPlus/Pro
control unit enriches the fuel mixture when the engine is started. The amount of enrichment depends on the
engine temperature and the ethanol content of the fuel used.
The eFlexPlus/Pro control unit includes predefined startup maps for each startup enrichment step. Using
predefined maps, most cars start even in colder conditions. However, you can make changes to these maps if
you have problems starting the engine:

Basic enrichment
in %.
Engine
temperature

Startup enrichment
cards (modifiable)

eFlexPlus Cold start
Base Cards

Percentage of
ethanol

Final Enrichment
in %

Instructions for starting the engine:




Avoid lengthy startup attempts. This consumes the starter motor and quickly drains the car battery.
If the engine does not start, pause for a few seconds before further attempts.
If possible, use engine preheating, especially in colder climates.
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Startup enrichment steps
The startup enrichment of the eFlexPlus/Pro control unit is a four-step process. The control unit has standard
values ready for each startup enrichment step. Changes made in the startup enrichment change the values of
the standard map to become richer or leaner.
Each step has its own parameters, which can be changed if necessary. The table below and the figure below
show in detail each stage of the startup enrichment:

Step
1
2
3
4

Description
Crank start (Crank)
Crank hold
Start of engine warmup (Warmup hold)
Warmup decay suite (Warmup decay)

Duration and objective
Define the number of injection pulses (engine starts).
Define the number of injection pulses (confirm engine start).
Set the time in seconds (improve cold engine starting).
Set the time in seconds (make sure the engine is running cold).

NOTE!
The amount of enrichment [%] shown in the figure above is illustrative. The final amount of enrichment
depends on the ethanol content of the fuel and the engine temperature. Enrichment decreases gradually, with
the highest enrichment given in step 1 and the lowest in step 4.
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Adjust enrichment at engine startup
The purpose of engine starting enrichment is to start a cold engine properly. Once you have changed the
engine startup settings, you can't be sure of the effect until the next time the engine is cold.

Notes on engine startup adjustments:




Make only moderate changes (Max. ± 20% at a time).





Start adding changes by adding a higher value. If that doesn't work, try a lower value.

Make changes in only one Startup Enrichment step at a time to better verify the effect of individual changes.
Values that are too rich can drown the spark plugs and prevent the engine from starting. Wait a few seconds before attempting a
new start.
In cold climates, some engines may require multiple start attempts, regardless of settings.
If the adjustments do not improve starting, add a few gallons of gasoline to the fuel tank with ethanol.

3

The enrichment rate for each start enrichment step is
modified from the control chart:




Adjustment values for changing the amount of enrichment (1).
Engine temperature (2).
Ethanol content (%) in the fuel (3).

2

1

The adjustment values change the enrichment percentage:






Adjustment range 0 - 255
100%, eFlexPlus/Pro basic value for startup
< 100%, decrease enrichment
> 100%, increase enrichment
0%, no startup enrichment

The following sample map has been modified as follows:
1.

2.

The initial enrichment is increased by 20% (set point 120%) with an
ethanol content of 65 to 75% and engine temperatures of -10 to -15°C
(14 to 5°F).
Startup enrichment is reduced by 20% (set point 80%) with an ethanol
content of 30 to 50% and engine temperatures of 5 to 10°C (41 to 50°F).

2
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Startup Improvement Map Tools Menu
The tools menu is opened by right-clicking on
the setting values. The tools affect the selected
cells on the map.

NOTE!
Changes made to the control card are
immediately written to the memory of the
control unit when the Bluetooth connection is
active.

Description of the tools in the Options menu:

Set



Opens the parameter window Set value
Defines the value given for all selected control chart
(here for example 120%).

cells

Change



Opens the parameter window Change value



Calculation example: 100 - 10 = 90%.

Defines the value given for all selected control chart
(here for example -10)

cells

Multiply



Opens the Multiply value parameter window.



Calculation example: 100 * 1.25 = 125%.

Defines the value given for all selected control chart
cells (here for example 1.25)

Zero correction


Sets the value of all selected control chart cells to
100%.



A starting enrichment value of 100% is given by the
standard estimation of eFlexPlus/Pro (no own
correction).
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Interpolate
The Interpolate tool automatically calculates and
adjusts values between selected control chart
frames.
In this example, the following changes have been
made to the control chart:


50% ethanol and engine temperature -20°C (4°F), set the value to 110%.



85% ethanol and engine temperature -20°C (-4°F), set
the value to 140%.



85% ethanol and engine temperature 0°C (32°F), set the
value to 120%.

The cells between the adjusted values always
have default values of 100%. Their adjustment
values are adjusted automatically so that the
transition between the adjusted values is as
smooth as possible.
Select the setting tables in the control chart by
clicking and dragging so that the changed values
are in the corners of the selected area:

When the check cells are highlighted, select the
Interpolate tool:

As a result, the range between the adjusted
values is automatically filled so that the
adjustment values between them change
uniformly.
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Copy from ...


Copy the values to the selected cells of the second
startup enrichment control chart



The values are copied only from the area of the
selected cells.
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Startup enrichment Step 1 (Startup crank)
1

The Startup Crank Enrichment Adjustment Map
Step 1 can be found in the Startup Crank (1)
tab.
The enrichment rate is defined using the
Correction (%) table (2) and the Pulse Count in
the table (3).



3

2

Adjustment range between 0 and 255
Number of pulses between 0 and 50

ATTENTION!
Avoid large adjustments in the number of pulses.
Make only ± 2 changes at a time. Too many
pulses can wet foul the spark plugs.

Startup enrichment 2 (Startup crank hold)

1

The Startup Crank Enrichment Adjustment Map
Step 2 is located in the Startup Crank Hold tab
(1).
The enrichment is defined using the Correction
(%) table (2) and the Pulse Count in the table
(3).



2

Adjustment range between 0 and 255
Number of pulses between 0 and 100

ATTENTION!
Avoid large adjustments in the number of
pulses. Make only ± 2 changes at a time. Too
many pulses can wet foul the spark plugs.
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1

Startup enrichment 3 (Startup warmup hold)
The Startup enrichment adjustment map
step 3 can be found in the Startup warmup
tab (1).
The amount of enrichment is defined by
Correction (%) in the table (2) and the
phase duration in seconds in the Hold
duration table (3).



2

3

Adjustment range between 0 and 255
Phase duration between 0 and 60 sec

Startup enrichment 4 (Startup warmup decay)

1

The Startup warmup enrichment adjustment
map step 4 can be found in the Startup
warmup tab (1).
The amount of enrichment is defined by
Correction (%) in the table (2) and the phase
duration in seconds in the Decay duration
table (3).



2

Adjustment range between 0 and 255
Phase duration between 0 and 200 sec

ATTENTION!
Avoid lengthy decay times. If the decay time is too long, the engine control unit (ECU) may give an error code
for an excessively rich mixture. The time must be shorter than the starting enrichment time of the engine
control (< 120 sec).
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Examples of startup enrichment control
On some car models, the eFlexPlus/Pro control unit only switches on when the engine is running. In this case,
you will not be able to change the machine settings until you start the engine. This may have an impact on the
setting of the cold start parameters.

NOTE!
If you do not connect to the control unit until the engine is running, you can check the operating parameters of
the control unit for startup enrichment in the Control unit status monitoring tab (see page 86). You can use this
information to make any necessary adjustments.

The engine does not start at all
If the engine does not start at all, then you can adjust the start enrichment step 1. At this step, the engine
receives some very rich injection pulses to facilitate ignition of the cold fuel.
In this example, the ethanol content and engine temperature are as follows:
Ethanol content
Engine temperature

1.
2.
3.
4.

78%
-12°C
(10,4°F)

Open the startup crank tab.
Increase the start enrichment in the problem area by
20% (final value is 120%).
You can also increase the number of injection pulses in
Pulse count.
Try starting the engine.

The engine starts but stops immediately
If the engine starts but stops immediately, you may want to adjust the start enrichment step 2. At this step,
the engine receives a few rich injection pulses to help keeping it running after the start.
In this example, the ethanol content and engine temperature are as follows:
Ethanol content
Engine temperature
1.
2.
3.
4.

50%
0°C (32°F)

Open the Startup crank hold tab.
Increase the start enrichment in the problem area by
20% (final value is 120%).
You can also increase the number of injection pulses in
Pulse count.
Start the engine again.
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The engine starts but stops after a few seconds
In case the engine starts well but stops after a few seconds, it is advisable to adjust the start enrichment
step 3. In this step, the fuel mixture is kept rich for a few seconds in order to stabilize the engine run.
In this example, the ethanol content and engine temperature are as follows:
Ethanol content
Engine temperature

1.
2.
3.
4.

66%
-18°C
(-0,4°F)

Open the Startup warmup tab.
Increase the start enrichment in the problem
area by 20% (final value is 120%).
Under Hold duration increase the duration by
3 seconds (setpoint 5 s → 8 s).
Observe the effect of the changes the next time
the engine is started.

The engine starts well but it is difficult to start driving
When the engine starts well but does have normal throttle response for the first minute of driving, it is
advisable to set the start enrichment step 4. In step 4, the enrichment is gradually reduced to zero, but the
rate of change can be changed.
In this example, the ethanol content and engine temperature are as follows:
Ethanol content
Engine temperature

1.
2.
3.
4.

66%
-18°C (-0,4°F)

Open the Startup warmup tab.
Increase the start enrichment in the problem
area by 20% (final value is 120%).
Under Decay duration, increase the phase
duration by 30 seconds (setpoint 50 s → 80 s).
Observe the effect of the changes the next time
the engine is started.
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Fuel injector settings (eFlexPlus & eFlexPro)

The adjustment program can be used to make changes to the fuel injector parameters of the eFlexPlus/Pro
control unit.
The parameters of the fuel injectors can be found in the adjustment program under the "Injectors" tab (1):
1

2

NOTE!
Changes to the fuel injector settings are immediately stored in the control unit's active memory if the Bluetooth
connection is active.

Injector dead time (Fuel injector delay)
Due to the structure of the fuel injector, there is always a delay between opening and closing. The length of
the delay varies among fuel injectors in different vehicles. Use the slider to change the delay setpoint used by
the eFlexPlus/Pro control unit (2).





Basic setpoint value is 0.750 ms (works well in most vehicles).
Adjustment range 0.450 - 1.050 ms.
Decreasing the value will enrich the fuel mixture at idle.
Increasing the value will dilute the fuel mixture at idle.

The eFlexPlus/Pro control unit uses the fuel injector delay setpoint to calculate the actual fuel flow:




Affects the linearity of the enrichment of the control unit over the entire operating range of the engine.
Maximum impact at engine idle, low RPM level and low engine load.
Affects the engine emission values (e.g. NOx,).

ATTENTION!
Only change this value if the SHORT TERM FUEL TRIM correction value indicated by the engine control unit
shows a clear difference at engine idle speed and at higher RPM levels. Make only small changes at a time
(MAX ±0.100 ms).

81

eFlexTuner User Guide

19.

StepOne Tech Oy

Reading and resetting of control unit error codes
1

The eFlexPlus/Pro control unit includes an error
code memory. Error codes can be read and reset
using the adjustment program.
 The descriptions of error modes are clear and easy to
interpret.



Start the engine.



Connect to the control unit via Bluetooth.



Select the "Fault codes" tab (1).



Error codes that are active in the eFlexPlus/Pro control unit
are displayed under the heading "Active" (2).




4

The stored error codes are not active, so they do not
affect the current operation of the control unit.

To clear error codes, click the "Clear faults" button (4).


3

Active error codes can affect the current operation of
the control unit.

Error codes of the eFlexPlus/Pro control unit that have
been saved are displayed under the heading "Stored" (3).




2

If the error code is still active, it will reappear after a
certain time under the heading "Active" (2).
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Monitoring the status of the control unit

The status of the eFlexPlus/Pro control unit can be
monitored by means of a setting program:


Start the engine.



Connect to the control unit via Bluetooth.



Select the "Status" tab (1).



The engine control injector channel activity is indicated by
the indicator light under "Injector channel activity" (2).
When the injector is active, the corresponding light is on
(light blue).



1

2
3

4

The indicator light for the ethanol sensor lock is shown
under "Sensors". The lock indicator (3) is lit (black) when
the ethanol sensor is not read. The interlock is activated
under certain engine operating conditions:
 When the fuel injector rate is more than 50% (at
higher engine power), the fuel line may be empty.
 When the fuel injector usage rate is 0% (the fuel pump
may not be running).
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The operating parameters for the startup enrichment
are listed under "Startup" (4). Here you can also check
which parameters were used to start the engine:
Activate:
Phase:
Correction:
Startup temperature:
Crank pulses:
Crank hold pulses:
Hold duration:
Decay duration:

The LED is lit when enrichment at startup is active.
The active phase of enrichment at startup.
Active control value for enrichment at startup (control chart value for each phase).
Engine temperature at start up.
The number of injection pulses given in the enrichment step at start 1.
The number of injection pulses given in the enrichment step at start 2.
The enrichment hold time used in enrichment step 3 at startup.
The enrichment decay time used in enrichment step 4 at startup.
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3D display of fuel maps

The eFlexPlus/Pro fuel cards can be viewed in 3D:


Select the "3D maps" tab (1).



Use the selection keys to select the fuel card to be
displayed (2).



To rotate the 3D image to different positions, hold down
the left mouse button and move the mouse pointer.
Right-click to return to the standard view (3).



The selected cells on the displayed fuel map will appear
yellow in the 3D image (4).

1

2
3

4

The parameters of the 3D display can be
changed via the parameter window of the
adjustment program (see page16).

84

eFlexTuner User Guide

22.

StepOne Tech Oy

Log (eFlexPlus & eFlexPro)

The operating parameters of the eFlexPlus/Pro control unit can be stored in the log while driving. The log can
be saved on a computer and can be viewed later.

Saved in the log file:


All operating parameters of the eFlexPlus/Pro control unit are stored in the unit.

Characteristics of the log files:




The file extension of the log file is .efl
The default location on the computer is in a sub-folder of the setup program ...\Logs
CSV file format: the file extension can be converted to .csv format by replacing .efl by .csv

Log Screen
To open the log screen, select the "Log" tab (1).
1

Parts of the log screen:


2

Operating parameters to be displayed in the log (2).
 To select the operating parameters to be displayed on the
log screen in the configuration settings, see page16.



Maximum values for the displayed operating parameters
(3) (throughout the log).



Minimum values for the displayed operating
displayed (4) (throughout the log).



Log navigation bar (5).



Log action buttons (6).

3

4

5



Log operating parameter curves (7).



Vertical line indicating the position (in time) of the log reading
(8).



Values of the operating parameters at the
current position in the logbook (9).



Time stamping of the current position in the logbook (10).

6

7

8

9
10

85

eFlexTuner User Guide

StepOne Tech Oy

Changing Log Settings
You can change the log settings by clicking the Settings
action button on the log screen.
This opens the configuration screen tab of the "Log"
setting program:
Changing the log settings is explained in more detail on
page16.

Collect the log
The log can be collected while driving. All operating
parameters of the control unit are stored in the
logbook.

Steps for collecting the log:


Start the engine.



Connect to the control unit via Bluetooth.



Start logging by clicking the ‘Record’ action button on the log
screen.
 The background color of the action button turns red when
logging is active.



1

 Operating parameter curves (1).
 Current values of the operating parameters (2).
 Log duration in seconds (3).



2

Values displayed during recording :

3

The setup program will display an error message if the
recording is started without a Bluetooth connection:
 To close the error message, click OK.
 Establish Bluetooth connection.
 Restart the log.



Stop logging by clicking the ‘Stop’ action button on the log
screen.

Save the log to a file
You can save the collected log to a file by clicking the Save action button on the log screen.

Opening the log from a file
You can open the log file by clicking the Open action button on the log screen.
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Display of log files
Log files can be displayed using the log screen.
When the log display is active, the entire control view is updated according to the log file.

NOTE!
The Bluetooth connection to the control unit cannot be active while the log file is being displayed.


Select the control unit from the menu bar to disconnect Bluetooth from the Device → Disconnect unit or click the Bluetooth
disconnect action button

.

Steps to view the log:


Open the log file (if the log file is not already open).



To start viewing the open log file, click the Play action button on
the log screen.
 The background color of the action button turns green
when the log display is active.



You can select the point to be displayed in the log:

1

 By clicking on the operating parameter curves at the
desired position (1).
 By clicking on the navigation bar of the log screen (2). To
browse the log, hold the left mouse button on the
navigation bar and drag the mouse pointer left and right.



You can zoom in and out of the log by scrolling the mouse
wheel over the operating parameter curves on the log
screen.



To stop displaying the log file, click the ‘Stop’ action button

2

on the log screen.



To go to the beginning of the log, click the ‘Back’ action button
on the log screen.



To go to the end of the log, click the ‘Forward’ action button on
the log screen.
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Log analysis tool (eFlexPro)

The log files of the eFlexPro control unit can be viewed using the Log analyzer tool. It makes it easier to
understand the relationship between the values stored in the log. The analysis tool can display the entire log
or only a specific time interval.
The Log analyzer tool allows you to view a new log or a previously saved log.
For information on how to collect the log or open an old log, see pageError! Bookmark not defined.

Analysis tool window
Open the log analysis tool window by selecting the "Log analyzer" tab (1).

Content of the window:


z-axis information (selected parameter and value-based
color coding) (2).



Information of the y-axis (selected parameter and
scaling) (3).



Information of the x-axis (selected parameter and
scaling) (4).

1

2

3

4



Analysis view (coordinate system) (5).



Log time interval controllers (start and end) (6).



Action buttons of the log analysis tool (7).

5

6
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Changing axis parameters
If the log to be analyzed does not appear as desired in
the analysis tool view, the operating parameters
displayed on the axes and their range of values can be
changed.
The image on the right shows a situation in which the
sampling points of the log appear in a very small area of
the analysis view:

Problems noted in the sample:


The engine RPM range displayed on the x-axis is 0 - 25500 RPM.
The engine RPM range stored in the logbook is much narrower,
0 - 6000 RPM.



The value range of analog input 1 represented by the y axis is 0
- 255 [RAW]. The value range of analog input 1 stored in the
logbook is much narrower, 60 - 225 [RAW].

To modify the operating parameters and their range of
values displayed on the axes, click the Settings action
button

(1).

This opens the Settings window:

1

1
2

Solving the problem:


Define the RPM range of the engine displayed on the x-axis 0 - 6000
RPM (1).



Define the value range of analog input 1 represented by the y-axis 60
- 225 [RAW] (2).

Click Save to apply the new settings.
See page 17 for details on how to change the settings.

Once the axis value ranges of the log analysis tool are
corrected, all sample points in the log fit well within
the entire analysis view area:
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Selecting the log time interval
The log analysis tool displays the entire log by default.
There are two different ways to reframe what appears
in the log:

Cropping time
You can use the cursor commands in the analysis tool to
define the time frame shown in the log (1):
Cropping is active when the action button
(2).


is displayed

Use the sliders to select the start and end points for the log.

2
1
3

Cropping through the log view
You can also use the log screen to crop the time frame
that the analysis tool displays from the log:


Go to the "Log" tab (3).



Select the log point with the navigation bar (4).



You can change the scale of the log screen by hovering over the
screen and scrolling the mouse wheel (5).



The analysis tool displays the log interval that corresponds to
the log screen (6).

6
5
4
7



Return to the "Log analyzer" tab (7).



Activate the cropping of the selected point in the logbook by
clicking the action button (8). At the same time, the icon of
the action button changes to , indicating that the link to the
log screen is active.

9

 The points in the analysis view are updated to reflect the
point selected in the log view (9).
 The interval cursors of the analysis tool are locked
and next to them there is a link text "Linked" (10).

8

Examples of analysis

10

Here are two examples of how the log analysis tool can
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identify potential problems related to eFlexPro hardware adjustments and how these adjustments affect the
engine performance.

NOTE!
Connect the eFlexPro control unit to at least one of the engine load sensors (TPS, MAP, MAF). Without
recording the engine load, it is virtually impossible to analyze the log. For more information on using engine
sensors, see page32. We also recommend the use of a broadband lambda sensor. This allows the engine fuel
mixture to be used to support adjustments to the fuel card.

Fuel injector usage rate
The analysis tool can easily check how the fuel injector
usage rate behaves in different driving situations. The
utilization rate of the injectors indicates whether the
fuel supply capacity of the engine is sufficient with the
current adjustments. If necessary, the fuel supply can
be increased further.
In this example, the eFlexPro control unit is connected
to an Air Mass Flow meter (AMF). The AMF is connected
to analog input 1.
The axes are configured as follows:
Axis
x
y
z

Operating parameter
Engine RPM (RPM)
Engine air mass flow meter (Analog in 1)
Fuel injector duty cycle (Injector duty cycle)

From the sample log in the picture, we see that the fuel injector utilization rate has reached a safe maximum
value of 78%. The color of the sample points also indicates that the duty cycle increases normally and steadily
as the engine load increases.

Fuel mixture at different engine load levels
With the analysis tool you can quickly examine how an
engine fuel mixture behaves under different engine load
conditions. This can be used to locate load situations
requiring adjustment, which can be corrected by the
Load Enrichment Control Card (page52).
In this example, the eFlexPro control unit is connected
to an air mass flow meter and a broadband lambda
sensor. The air mass flow meter is connected to the
analog input 1 and the broadband lambda sensor
control unit is connected to analog input 2.
The axes are configured as follows:
Axis
x
y
z

Operating parameter
Engine RPM (RPM)
Engine air mass flow meter (Analog in 1)
Broadband lambda sensor (Analog in 2)

From the sample log in the image, it can easily be noted that the engine fuel mixture has remained within the
safe range of 14.7 AFR or richer throughout the operating range. The color of the sample points also indicates
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that the fuel mixture changes uniformly and has no lean points. The only lean areas marked in red are the
result of the engine braking when the fuel supply is cut off.
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Overview of gauges

engine RPM





 ”Injector duty cycle”
 Unit [%]
 Value range 0 - 100%.

"RPM"
Unit [RPM]
Value range 0 - 25500 RPM
Upper limit is adjusted to the highest
value read

Ethanol content of fuel





Fuel injector usage rate

Engine temperature
 "Engine temperature"
 Read value of the cable harness
temperature sensor
 Unit [°C]
 Value range -40 - 120°C (-40 - 284°F)

"Fuel ethanol content"
Value read from the ethanol sensor
Unit [Vol-%]
Value range 0 - 100%.

RPM enrichment adjustment value
 "Fuel map"
 Displays the active value of the RPM
Enrichment Setting Chart (pages44
and52)
 Unit [Corr %]
 Value range 0 - 255%.

Adjustment value of the start
enrichment

Ethanol enrichment adjustment
value
 "Ethanol content comp."
 Displays the active value of the ethanol
enrichment setting chart (page37)
 Unit [Corr %]
 Value range 0 - 255%.

Fuel temperature
 "Fuel temperature"
 Active value read from the ethanol
sensor
 Unit [°C]
 Value range -40 - 120°C (-40 - 284°F)

 "Startup correction"
 Displays the active value of the start
enrichment setting card (page71)
 Unit [Corr %]
 Value range 0 - 255%.

Analog input 1 (Pro)

Analog input 2 (Pro)

 "Analog in 1"
 Displays the value of the sensor
connected to analog input 1
 Standard Unit [RAW]
 Value range 0 - 255 (equivalent to 0 5V)
 Can be linked to sensor file
(page15)

 "Analog in 2"
 Displays the value of the sensor
connected to analog input 2
 Standard Unit [RAW]
 Value range 0 - 255 (equivalent to 0 5V)
 Can be linked to sensor file
(page15)

Adjustment value for sensor
enrichment (Pro)
 "Analog in map"
 Displays the active value of the sensor
enrichment adjustment chart (page63)
 Unit [Corr %]
 Value range 0 - 255%.
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